Encountered this one whilst trying to upgrade from AIX 5.3 ML5 to TL7.
The upgrade fails because it cannot extend hd5 by enough contiguous physical partitions. In my case by 2 PP’s.
I could see using lspv -M hdisk0, that hd5 had the first PP, but another LV had the next, so I could not extend hd5.
I did the following to move hd5 to different PP’s on hdisk0, but this could be used to move to another disk should hdisk0 not have enough free (contiguous) PP’s. My upgrade then worked ok.

Note : It’s prudent to ensure you have a valid mksysb prior to doing this.

Find enough free, contiguous PP’s using the lspv -M hdisk0 command. At the end of my list I saw:

hdisk0:602-639

Since no LV name is in this entry, these are free PP’s.
I need 3 PP’s for my new hd5 (BLV) so I create a map file with:

echo "hdisk0:602-604" > /tmp/hd5_mapfile

Now I remove the existing hd5

rmlv -f hd5

Create a new hd5 with: –

mklv -y hd5 -t boot -m /tmp/hd5_mapfile rootvg 3

3 is the number of PP’s
Next clear the existing boot record from hdisk0

mkboot -d /dev/hdisk0 -c

Then re-create the boot image with

bosboot -a -d /dev/hdisk0 -l /dev/hd5

In my case, I wasn’t sure about savebase, so I ran it and then re-ran just a bosboot -a.
Check your bootlist is correct

bootlist -m normal -o

and correct if necessary.
Then you should be good for a reboot to test hd5 is ok.